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Appendix A 

Keyboard Commands and 
Shortcuts

Overlooked Commands 

Command: Shortcut:

File Menu 

Close All Cmd+Option+W (Ctrl+Alt+W)

Save As Choose from 18 formats (more through special plug-ins). Photoshop is the 
ultimate graphic converter. Shift+Cmd+S (Shift+Ctrl+S)

Save for Web It doesn’t get any more intuitive. Choose the two-up window, resize and 
compress your image for the web or e-mail. Now you can safely send the client 
an approval copy without having to worry about messing up your original. 
Shift+Option+Cmd+S (Shift+Alt+Ctrl+S) 

Place Can’t open it? Try placing it. This is how you can bring in EPS, AI, or PDF files. 
It allows you to position and scale an image (via a bounding box). When you 
click OK, Photoshop will rasterize it at the proper size, position, and 
resolution.

Automate Submenu These are some of the most useful tools for preparing client comps. Whether 
for print, web, or e-mail, the Automate options take boring tasks and make 
them quick and easy. Think of this menu as Photoshop’s batch rendering 
option. (Think of batch rendering as the only chance you may get for caffeine, 
nicotine, or vending machine—the vices for an editor.) To learn more, see 
Chapter 11, “Automation.”

Keyboard shortcuts are the 
secret to unlocking 
Photoshop’s speed. More 
than any NLE, Photoshop 

relies on key combos to get complex 
tasks done quickly.
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Edit Menu 

Step Forward and 
Step Backward

Multiple undos. See Chapter 6, “A Sense of History.” The keyboard shortcut 
varies based on your user-specified preferences in the General Preferences tab.

Fade Not happy with the results of a filter or an adjustment? Choose this 
immediately after running the filter. By the way, did I mention this adds 
blending modes to all filters? Your filter collection just grew 2100%. Try it now! 
Give your filters new life! Remember: you must choose this immediately after 
running a filter. This is quite possibly Photoshop’s most underused feature. 
(Shift+Cmd+F/Shift+Ctrl+F)

Copy Merged Copy multiple layers into one layer on your clipboard. Why flatten unnecessarily? 
(Shift+Cmd+C/Shift+Ctrl+C)

Check Spelling,
Find and Replace 
Text

We asked; Adobe listened. In my opinion, worth the upgrade price alone. 
(Literally, because spelling errors are generally nonbillable).

Free Transform This tool does it all. Access every layer transformation by Ctrl+clicking (right-
clicking) while in free transform mode. Cut downs on image degradation by 
applying all your sizing, warping, and perspective changes at once. Cmd+T (Ctrl+T)

Purge Free up space by deleting undos, clipboards, history! This will enable you to save 
and close when you get the dreaded “Scratch Disks Are Full” message.

Layer Menu 

Group and Ungroup Similar to using a track matte. Apply a layer to its downstairs neighbor, but 
only in areas where there is opacity. This is often used to constrain a fill layer to 
a lower text layer for a Paste Into effect. It is also used internally by many layer 
styles to create proper clipping for bevel effects. Group: Cmd+G (Ctrl+G) 
Ungroup: Cmd+Shift+G (Ctrl+Shift+G)

Arrange Layers You can move layers around from the keyboard. 

Bring to Front  Cmd+Shift+[ (Ctrl+Shift+[) 

Bring Forward Cmd+[ (Ctrl+[) 

Send Backward Cmd+] (Ctrl+])

Send to Back Cmd+Shift+] (Ctrl+Shift+])

Align Linked and 
Distribute Linked

Because your eyes aren’t that good. Link the layers together and access these 
controls from the menu (or use the Move tool and Options bar for a graphical 
interface). Want something centered on the screen? Link to the background layer 
and highlight it. The highlighted layer is the basis for all centering and distribution.

Overlooked Commands (continued)

Command: Shortcut:
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Select Menu 

Reselect Brings back the last selection made, even if it was a long time ago. 
(Shift+Cmd+D/Shift+Ctl+D)

Feather Proper feathering is the difference between good glows and shadows and bad 
ones. It is also a critical step when creating masks and alpha channels. Use this 
method to feather after you have made a selection. Several tools have their own 
feathering which can be applied from the Options bar. Cmd+Option+D 
(Ctrl+Alt+D)

Select Color Range This tool uses an interface similar to After Effects Linear Color Key effect. Use 
the Eyedropper to click on the color you want to select, then add or subtract 
with the Plus and Minus Eyedroppers. You can smooth your selection out 
using the Fuzziness slider. This powerful selection tool does not get enough 
use.

View Menu 

Zoom In Cmd++ (Ctrl++)

Zoom Out Cmd+– (Ctrl+–)

Fit On Screen Cmd+0 (Ctrl+0)

Show Actual Pixels Cmd+Option+0 (Ctrl+Alt+0)

Show Hide selections and guides. Very useful to see your work and nothing else. By 
the way, slices are for the web. If you see annoying white numbers in the corner 
of your document, you’ve turned slices on accidentally (by selecting the Slice 
tool, for example). Get rid of them by accessing View>Show>Slices and 
unchecking it. To hide all, press Cmd+H (Ctrl+H)

Snap Use those guides for something useful. Objects will snap to position as you drag 
them near a guide. (Shift+Cmd+;/Shift+Ctrl+;)

New Guide A more precise way to add guides to your project. Choose View>New Guide 
and specify an exact location.

Window Menu 

Cycle through open 
windows

Ctrl+Tab

Hide Tools Tab

Steal Attributes for 
New Image Size or 
Canvas Size

This one is tricky. By default, Photoshop offers to make a new document from 
the size of the image on your clipboard. You can choose from more options, 
however. First, make a new window. Before clicking OK for the size, access the 
Window menu. You can now select from any open document in the list.

Overlooked Commands (continued)

Command: Shortcut:
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Help Menu 
There is no shame in using the Help menu. It’s all there (at least the dryly written official answer). The 
Help menu allows you to keep the users manual in a quick access format (it uses a standard web browser).

System Info You’ll need this when calling tech support. It’s also a great way to call up a list of 
all your filters so that you can check on manufacturer’s web sites for updates.

Adobe Online Get updates and news on your favorite products. You can access software 
updates directly.

Full Screen Modes
One picture at a time, please! Cutting down on clutter can be tough with all of Photoshop’s floating 
palettes and open windows. Fortunately, there are two full-screen modes that help you isolate your active 
window. You can cycle through these by pressing the F key. If you’d like to apply a full-screen mode to all 
open documents, Shift+click on the corresponding icon.

Full Screen Mode 
With Menu Bar

This mode puts you into a windows-like environment where the active window 
blocks the others out. The area outside your image is filled with gray, and scroll 
bars disappear. You can cycle to other windows by pressing Ctrl+Tab or 
selecting the item from the Window menu.

Full Screen Mode This mode blacks out the background and loses the menu bars. To complement 
this environment, press the Tab key to hide all of your palettes, and press 
Cmd+0 (Ctrl+0) to zoom your image to full screen. This mode works well for 
reviewing and approving images. The Ctrl+Tab shortcut will work here as well 
to cycle through open windows.

Overlooked Commands (continued)

Command: Shortcut:
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Shortcuts
There are many valuable shortcuts when it comes to layers. Think of the Layers palette as your timeline,
and you will grasp the importance of mastering these. And remember, you can activate multiple visibility
and link switches by clicking on one then dragging through the other layers in the palette. 

Layer Shortcuts 

Command: Shortcut:

Load a Layer Cmd+click (Ctrl+click) on layer icon

Add to Loaded Layer 
selection

Shift+Cmd+click (Shift+Ctrl+click) on other layer icons

Subtract to Loaded Layer 
selection

Cmd+Option+click on other layer icons 
Ctrl+Alt+click on other layer icons

Activate Layers palette F7

New Layer Cmd+Shift+N (Ctrl+Shift+N) or Click on New Layer button

New Layer via Copy Cmd+J (Ctrl+J)(must have item selected)

New Layer via Cut Cmd+Shift+J (Ctrl+Shift+J) (must have item selected)

Duplicate Layer Cmd+J (Ctrl+J) or Drag Layer to the New Layer Button

Delete a Layer Click Delete Layer Button or Drag Layer to the Delete Layer Button

Delete Multiple Layers Step 1 Link them together.

Step 2 Cmd+click (Ctrl+click) on the Trash icon in the Layers palette. 

Solo a Layer Option+click (Alt+click)on Eye icon

Activate Next Visible Layer Option+] (Alt +])

Activate Previous Visible 
Layer

Option+[ Alt+[)

Activate Top Layer Option+Shift +] (Alt+Shift +])

Activate Bottom Layer Option+Shift+[ (Alt+Shift+[)

Move a Layer Up One 
Position

Cmd+] (Ctrl +])

Move a Layer Down One 
Position

Cmd+[ (Ctrl +[)

Move a Layer to Top Cmd+Shift +] (Ctrl+Shift +])

Move a Layer to Bottom Cmd+Shift+[ (Ctrl+Shift +[)
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NOTE: Holding down the Shift key while changing a type layer’s attributes in the Character or Paragraph
palette will change the same attribute on all linked layers.

Change Opacity by 10% 
increments

Type a single number (i.e., 3 = 30%)

Change Opacity by 1% 
increments

Type two numbers quickly (i.e., 67 = 67%)

Cycle through Blend 
Modes 

(must have tool selected without blending modes)

Cycle to Next Blend Mode Shift++ (plus)

Cycle to Previous Blend 
Mode

Shift+– (minus) 

Convert a Background 
Layer

Double-click on icon and rename

Group Layer Option+G (Alt+G)
Option+click (Alt+click) between layers

Ungroup Layer Cmd+Shift+G (Ctrl+Shift+G)
Option+click (Alt+click) between layers

Merge Active layer Down Cmd+E (Ctrl+E)

Merge to Target Layer Link desired layers to target, choose Merge Linked from submenu of 
Layers palette

Merge to Target and 
Preserve Layers

Step 1 Create new target layer.

Step 2 Link desired layers to new target.

Step 3 Hold down Option (Alt) key and choose Merge Linked from
submenu of Layers palette.

Toggle Layer Mask Off/On Shift+click on Layer Mask thumbnail

Toggle Layer Mask and 
composite

Option+click (Alt+click) on Layer Mask thumbnail

Turn on alpha channel \ (toggles rubylith mask off/on)

Make Layer Active Cmd+~ (Ctrl+~)
Click on layer thumbnail

Modify Layer Mask View Double-click on Layer Mask icon

Layer Shortcuts (continued)

Command: Shortcut:



Type Shortcuts 229

Type Shortcuts 

Command: Shortcut:

Enter Edit Mode Double-click on T icon in layer palette

Reposition Type without exiting Hold down Cmd (Ctrl) and move with mouse

Toggle Eyedropper Option (Alt)

Select a Word Double-click on word

Select a Line Triple-click on word

Select a Paragraph Quadruple-click on word

Select All Cmd+A (Ctrl+A)

Cycle through fonts Click in Type field in Options bar and use up and down arrows to 
select font

Adjust point size Click in Point Size field in Options bar and use up and down 
arrows to adjust size

Adjust point size of selection Cmd+Shift+< or > Ctrl+Shift+< or >

Hide “reversed out” selection Cmd+H (Ctrl+H)

Create new type layer Shift+click with Type tool to create a new type layer (if you’re close 
to another type block)

Toggle Hyphenation Cmd+Option+Shift+H (Ctrl+Alt+Shift+H)

Kerning Shortcuts (place cursor between characters)

Increase by 2/100 Em Space Option+right arrow (Alt+right arrow)

Decrease by 2/100 Em Space Option+left arrow (Alt+left arrow)

Increase by 10/100 Em Space Cmd+Option+right arrow (Ctrl+Alt+right arrow)

Decrease by 10/100 Em Space Cmd+Option+left arrow (Ctrl+Alt+left arrow)

Leading Adjustment Shortcuts (must highlight text)

Increase by 2 points Option+down arrow (Alt+down arrow)

Decrease by 2 points Option+up arrow (Alt+up arrow)

Increase by 10 points Cmd+Option+down arrow (Ctrl+Alt+down arrow)

Decrease by 10 points Cmd+Option+up arrow (Ctrl+Alt+up arrow)

Select Auto Leading Cmd+Option+Shift+A (Ctrl+Alt+Shift+A)
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History Palette Shortcuts 

Command: Shortcut:

Redo Key Option 1 (Cmd+Z)/(Ctrl+Z)

Toggles Undo/Redo Cmd+Z (Ctrl+Z)

History State Backward Cmd+Option+Z (Ctrl+Alt+Z)

History State Forward Cmd+Shift+Z (Ctrl+Shift+Z)

Redo Key Option 2 (Cmd+Shift+Z)/(Ctrl+Shift+Z)

Toggles Undo/Redo Cmd+Option+Z (Ctrl+Alt+Z)

History State Backward Cmd+Z (Ctrl+Z)

History State Forward Cmd+Shift+Z (Ctrl+Shift+Z)

Redo Key Option 3 (Cmd+Y)/(Ctrl+Y)

Toggles Undo/Redo Cmd+Option+Z (Ctrl+Alt+Z)

History State Backward Cmd+Z (Ctrl+Z)

History State Forward Cmd+Y (Ctrl+Y)

Filter Shortcuts 

Command: Shortcut:

Extract Filter>Extract
Cmd+Option+X (Ctrl+Alt+X)

Repeat last filter Cmd+F (Ctrl+F)

Reopen last filter with same settings Cmd+Option+F (Ctrl+Alt+F)

Fade last filter Cmd+Shift+F (Ctrl+Shift+F)

Cycle Through Gradients Previous, (comma)/Next. (period)

Default Colors D

Toggle Foreground/Background X

Lighting Effects Filter

Duplicate light Option+drag light (Alt+drag light)

Delete Light Delete

Adjust light footprint w/o changing angle Shift+drag handle

Adjust light Angle w/o changing footprint Cmd+drag handle (Ctrl+drag handle)
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Retouching Tools

Toggle Blur and Sharpen Hold down Option (Alt) while using one of these tools

Toggle Fingerpainting Smudge Hold down Option (Alt) while using the Smudge tool

Toggle Dodge and Burn Hold down Option (Alt) while using one of these tools

Switch Modes while Toning Shadows: Option (Alt)+Shift+S
Midtones: Option (Alt)+Shift+M
Highlights: Option (Alt)+Shift+H
Cycle: Shift++ or Shift+–

Set the Sponge tool Desaturate: Option (Alt)+Shift+D
Saturate: Option (Alt)+Shift+S
Cycle: Shift++ or Shift+–

Selection Shortcuts 

Command: Shortcut:

Add to a selection Shift+Selection tool

Subtract from a selection Option+Selection tool (Alt+Selection tool)

Create intersection selection Shift+Option+tool (Shift+Alt+tool)

Select All Cmd+A (Ctrl+A)

Deselect Cmd+D (Ctrl+D)

Reselect last selection Cmdl+Shift+D (Ctrl+Shift+D)

Inverse selection Cmd+Shift+I (Ctrl+Shift+I)

Hide Marching Ants Cmd+H (Ctrl+H)

Use Move tool temporarily Hold down the Cmd (Ctrl) key to temporarily switch
(Except with vector tools)

Use Hand tool temporarily Hold down the spacebar

Feather Cmd+Option+D (Ctrl+Alt+D)

Load a Layer Cmd+click (Ctrl+click) on a layer

Add to Loaded Layer Cmd+Shift+click (Ctrl+Shift+click) on a layer

Subtract From Loaded Layer Cmd+Option+click (Ctrl+Alt+click) on a layer

Intersect From Loaded Layer Cmd+Option+Shift+click (Ctrl+Alt+click) on a layer

Filter Shortcuts (continued)

Command: Shortcut:
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Load a Channel Cmd+Option (Ctrl+Alt) and the channel number
Cmd+click (Ctrl+click) on the Channel icon

Constrain Marquee Shift+drag with initial selection

Draw from Center with Marquee Option+drag (Alt+drag) with Elliptical Marquee

Reposition Selection as it’s drawn Hold down spacebar

Move Selection 1 pixel Arrow keys when Marquee/Lasso/Wand selected

Move Selection 10 pixels Shift +arrow keys when Marquee/Lasso/Wand selected

Move Selected Pixels 1 pixel Switch to Move tool; then use arrow keys 

Move Selected Pixels 10 pixels Switch to Move tool; then use Shift+arrow keys 

Center selection in new document Shift+drag selection to new document

Lasso Tool

Activate Lasso tool L

Toggle Lasso tools midselection Hold down the Option (Alt) key and drag

Close Selection Double-click or press Enter

Cancel Escape

Levels, Curves, and Color Shortcuts 

Command: Shortcut:

Levels

Levels Cmd+L (Ctrl+L)

Use Last Levels Settings Cmd+Option+L (Ctrl+ Alt+L)

Auto Levels Cmd+Shift+L (Ctrl+Shift+L)

Auto Contrast Cmd+Option+Shift+L (Ctrl+Alt+Shift+L)

Curves

Curves Cmd+M (Ctrl+M)

Use Last Curves Settings Cmd+Option+M (Ctrl+Alt+M)

Pinpoint Color on Curve Cmd+click (Ctrl+click) in image

Pinpoint Color on Each Curve Cmd+Shift+click (Ctrl+Shift+click) in image

Selection Shortcuts (continued)

Command: Shortcut:
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Color

Color Balance Cmd+B (Ctrl+B)

Use Last Color Balance Settings Cmd+Option+B (Ctrl+ Alt+B)

Auto Color Cmd+Shift+B (Ctrl+Shift+B)

Hue/Saturation Cmd+U (Ctrl+U)

Use Last Hue/Saturation Settings Cmd+Option+U (Ctrl+ Alt+U)

Desaturate Image Cmd+Shift+U (Ctrl+Shift+U)

Invert Cmd+I (Ctrl+I)

Levels, Curves, and Color Shortcuts (continued)

Command: Shortcut:
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