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Using Panoramic Photos for  
Motion Graphics & Video
One of the primary benefits of animating in After Effects is its support for 3D space. This makes it 
easy to position and animate objects along their X, Y, or Z-axes. Additionally, After Effects supports 
a rich system of lights and cameras, which make believable 3D animation even easier.
In this session, we’ll explore the process of creating elements and environments that can be used 
with 3D cameras or animated in 3D space. This material comes from the new book Flash for After 
Effects | After Effects for Flash from Adobe Press. The files have been made available for download 
to conference attendees by visiting: www.photoshopworld.com.

Creating Seamless Textures
A common element you’ll need to create for animated environments is seamless textures. These 
patterns can be repeated or looped to create a background animation. This can be anything from 
a looping pattern for a road or a gentle group of clouds floating in the sky. The key is to make a 
pattern that is seamless and large enough that the viewer doesn’t detect the loop.

Process in Photoshop
The first step to creating a seamless texture loop is to process the image using Photoshop. 
Essentially what you’ll do is wrap the image upon itself (much like a flat ribbon turned into a loop). 
Where the image wraps, blending must occur. Fortunately Photoshop offers several tools that 
make this process a snap.
	 1. From the Photoshop World website, download the lesson files to your computer.
	 2. If it’s not already running, launch Photoshop CS4.
	 3. Open the folder 01_Background then open the file cloud_start.psd.

Richard Harrington
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multimedia projects. He is the author of Photoshop for Video, Producing Video Podcasts, and Understanding Adobe 
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and www.PhotoshopforVideo.com.
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	 4. Choose Filter > Other > Offset… A new dialog box opens to control the filter.
	 5. Enter a value of 1000 into the Horizontal ___ pixels right box.
	 6. �Click the radio button to Wrap Around for Undefined Areas. The photo has now slide 

to the right and wrapped around to the other side. The image now has a seam in the 
middle that must  
be removed.

	 7. �Select the Clone Stamp 
Tool and choose a large 
brush (100 pixels or 
greater) with a soft edge.

	 8. Option-click (Alt-click) near the seam to set a sample point.
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	 9. �Clone the seam to try and hide the edge. In some cases you’ll be removing clouds, in 
other cases you’ll add them in. You can see the image cloud_end.psd as reference. Be 
sure to occasionally re-click to set a new sample point.

Be sure to frequently change your sample point. The goal 
is to blend the two sides of the image together with soft 
edged cloning strokes.
	 10. �Cloning will not entirely hide the seam. You’ll 

need to use the Healing Brush. Select the 
Healing Brush from the Tools panel. Use a 
soft-edged brush sized 200 pixels or bigger.

	 11. �Option-click (Alt-click) near the seam the set a 
sample point.

	 12. �Brush over the visible seams that remain. 
The most problematic areas are the blue-sky 
regions with different tonal values.

	 13. �Combine Healing Brush and Clone Stamp 
strokes until the seam disappears.

	 14. �To soften the image a little, choose Filter > 
Blur > Gaussian Blur.

	 15. Enter a value of 5 pixels and click OK.
	 16. �Choose Image > Adjustments > Levels to 

invoke the Levels command.
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	 17. �Click on an area of a cloud that should be white to properly set the white point. If 
you misclick hold down the Option/Alt key and click the Reset button.

	 18. Boost the color in the sky by choosing Image > Adjustments > Vibrance.
	 19. Enter a Vibrance value of 60 and a Saturation amount of 20.

	 20. Click OK.
	 21. Choose File > Save As.
	 22. Navigate to the lesson’s folder to save the file.
	 23. �Name the file cloud_pattern.psd and click Save. Close the open file. You are now 

ready to animate the file in After Effects.

Offset Effect in After Effects
Photoshop and After Effects have many similarities, from Layers and Blending Modes to Layer Styles 
and Effects. Just as you used to Offset filter in Photoshop to wrap an image, you can use the same 
effect in After Effects to animate the Offset. This makes it possible to animate a seamless pattern.
	 1. If it’s not running already, launch After Effects CS4.
	 2. From the Welcome Screen, click the New Composition button.
	 3. From the preset list, choose HDV/HDTV 720 29.97.
	 4. Name the Composition 01_Clouds.
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	 5. �Set the Duration 
to 30:00 and  
click OK.

	 6. �At the bottom 
of the Project 
panel, click the 
New Folder icon. 
Name the folder 
01_Background.

	 7. �Choose File > 
Import and import 
the file Cloud_
Pattern from the 
lesson’s folder.

	 8. �Drag the cloud_
pattern.psd file 
into the composi-
tion 01_Clouds.

	 9. Place both the composition and the psd file into the folder 01_Background.
	 10. Highlight layer 1 in the Timeline and choose Effect > Distort > Offset.
	 11. Press the Home key to return to the first frame of the composition.
	 12. Press E to see the effects applied to the layer.
	 13. Click the triangle next to the word distort to see the controls for the effect.
	 14. Add a keyframe by clicking the stopwatch for the Shift Center To property.

	 15. Press End to move the Current Time Indicator to the last frame of the composition.
	 16. Add a keyframe to the Shift Center To property.
	 17. Double-click the newly added keyframe to adjust its value.
	 18. Click the Units drop-down menu and change it to % of source.
	 19. �To make the image slide one full rota-

tion, add or subtract 100% from the 
value of the keyframe. To move the 
image to the left, enter a value of -50% 
or to the right enter 150%.

	 20. �Let’s preview the animation at a 
lower quality to see it more quick-
ly. In the Preview panel, set the 
Resolution to quarter and click the 
RAM Preview button.
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	 21. Watch the preview of the animation; notice how the clouds seamlessly loop.

Layering images to Create Depth
Now that we have one instance of the clouds animated, we can add a second to create the illusion 
of depth. Simply duplicating the layer is not enough. Instead we must set a different loop point 
and adjust the scale to create a difference in size. Finally the two layers can be blended together 
to seamlessly mix.
	 1. Select the layer in the timeline and choose Edit > Duplicate. A second copy is added.
	 2. �Press U to select all of the user added keyframes. Two frames for the offset  

property appear.

	 3. Double-click the first keyframe for the topmost layer. The X value is set to 50%.
	 4. Change the X value to 0% and click return.
	 5. Double-click the first keyframe for the topmost layer. The X value is set to 150%.
	 6. �You need this keyframe to be +100% from the first. Change the X value to 100% and 

click return.
	 7. �If blending modes 

aren’t visible, click the 
bottom at the time-
line labeled Toggle 
Switches/Modes. 
Remember, Blending Modes allow you to mix layers together based upon values like 
color or luminosity.

	 8. �Click the Blending Mode list and set the top layer to Lighten. This mode works best in 
this scenario as it drops out the darker areas of the sky without changing the intensity 
of the blue areas much.

	 9. �Lets mix the layers together with a little Opacity change. Press T to view the opacity 
controls for the top layer.

	 10. Set the opacity property to 80%.
	 11. �Now lets adjust scale so the top clouds so appear closer. Since they layer is at 100% 

scale already (the default size) let’s avoid scaling up which can pixelate the image. 
Select layer 2 in the timeline.

	 12. Press S to view the scale controls for the bottom layer.
	 13. Set the Scale to 70% so the bottommost clouds look smaller (hence further away).
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	 14. �In the Preview panel, click the RAM Preview button. Because the clouds have differ-
ent scales and offset points, the animation appears seamless and fluid.

Stylizing with Adjustment Layers
Adjustment layers have two major benefits. They speed up your design process as the allow you 
to quickly apply the same effect to multiple layers. Similarly, rendering is also faster as the adjust-
ment layer creates a composite of the layer below and applies effects to it. The use of adjustment 
layers improves rendering speed compared with applying the same effect separately to each of 
the underlying layers.
	 1. Click on the topmost layer in the timeline.
	 2. �Choose Layer > New > Adjustment Layer. An adjustment layer is applied to the top of 

the layer stack.
	 3. �Let’s simplify the animation for web compression using the Cartoon effect. Choose 

Effect > Stylize > Cartoon.

	 4. �Change the Render drop-down to Fill. This will avoid any dark strokes appearing in the 
shot.

	 5. Change Shading Steps to 12 and Shading Smoothness to 100.
	 6. �In the Preview panel, click the RAM Preview button. Because the clouds have different 

scales and offset points, the animation appears seamless and fluid.
	 7. �Choose File > Save to store the file. Navigate to the chapter folder and name the  

project 9_Progress.aep.
This animation is complete. You can choose to export it as a FLV video for use in Flash or render it to 
a movie file for use in a video project. For now, we’ll save it in the After Effects project for later use.

Creating Seamless Backgrounds with Photomerge
Panoramic photography is the practice of shooting multiple photos and then stitching them into 
a larger photo. If enough photos are taken, then a large panoramic image can be made. These 
photos can then be brought into After Effects to serve as a backdrop for chroma key footage.
Shooting Panoramic Photos Right
Want to start shooting your own panoramic photos? Here are a few tips to get the best results.
	 • �For best results use a tripod. Pros know that it’s better to use a tripod and slightly move 

the camera to create overlap. 
	 • �For even better results, get a tripod head that rotates and has degree markers. There 

are even specialized tripod heads that you can purchase from companies like Kaidan 
(www.kaidan.com) and Really Right Stuff (www.reallyrightstuff ) that make leveling and 
rotation much more precise.

	 • Set the camera into a portrait aspect ratio.
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	 • �Switch the camera out of auto mode and lock the exposure. This will help minimize the 
amount of changes as the camera pans.

	 • �Make sure there is at least a 15% overlap between each shot. Depending upon the type 
of lens you use, you will use between 2 and 24 exposures. More exposures mean less 
distortion and cleaner panoramic photos.

Merging Photos
Let’s try piecing together a full 360˚ VR photo. This particular shot is comprised of 24 exposures 
that capture an entire environment. These types of shots are very useful as they allow for great 
flexibility when combined with green screen footage. Photoshop makes the combining of mul-
tiple shots easy using the Automation command called Photomerge: 
	 1. �Choose File > Automate > Photomerge. Photomerge is a specialized “mini- applica-

tion” within Photoshop that assists in combining multiple images into a single photo.
	 2. �Click the Browse button and navigate to the Panoramics folder. Open the folder 03_

Photomerge then open the folder Panoramic Photos. This folder contains 24 images, 
the originals were much higher resolution, but have been compressed to save space 
for this lesson.

	 3. Press Cmd+A (Ctrl+A) to select all the pictures in the folder and click Open.
	 4. �There are several Layout options available that attempt to fix problems caused by pan-

oramic photography (such as distortion). A good place to start is Auto, which attempts 
to align the images but will bend them as needed.

	 5. �Select the check boxes next to Blend Images Together and Vignette Removal. These 
two options will attempt to blend the edges of the photos together and can hide 
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subtle differences in exposure.
	 6. �Click OK to build the panoramic image. Photoshop attempts to assemble the pan-

orama based on your choices in the dialog box. Due to the number of images, the 
process may take a few minutes.

Notice that the tree trunk appears on both the left and right edges. This image needs a little addi-
tional processing to create a completely seamless 360˚ photo.

Creating a Seamless Loop with an Action
The resulting image is quite large, but not a perfect loop. While the image can be seamless, the 
left and right edges have not been properly cropped to use the image as a circular loop. To fix 
this process would normally take several (tedious) steps. To solve this problem, we’ve created an 
action that will finish processing the full 360˚ panoramic image. 
	 1. Choose Window > Actions to call up the Actions panel.
	 2. �Click the submenu of the Actions panel and choose Load Actions. A new browser  

window opens.

	 3. Navigate to the Chapter’s folder and open the folder 03_Photomerge. 
	 4. Select the action Panoramic.atn and click Load.
	 5. �In the Actions panel, locate the Panoramics  

set (folder) and choose the Seamless  
Loop action.

	 6. �Click the Play selection button in the  
Actions panel.

	 7. �The image is now seamless on the left and right 
edges. A new dialog box invites you to crop the 
image as needed.
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	 8. Click Continue. The image needs a little bit cropped from its top.

	 9. Choose Image > Canvas Size.
	 10. Enter a new height of 1950 and set the Anchor point as shown.

	 11. Click OK. A dialog warns you that some clipping will occur. Click Proceed.
	 12. Choose Layer > Flatten Image to discard any layers.
	 13. �Choose File > Save As. Name the File Pano_360 and save it as a TIFF file to the folder 

03_Photomerge inside the chapter’s folder.
	 14. Click Save to write the file. A new dialog box pops-up for TIFF options.
	 15. Apply LZW image compression to reduce file size.
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Importing into After Effects
Now that you’ve created a full 360˚ VR photo, you can bring this into After Effects. By turning the 
image into a cylinder, you can place a 3D camera into the scene and add green screen footage 
to give you a virtual world. Because you have a full view, it makes it easy to simulate being at the 
particular location. 
	 1. Switch back to After Effects.
	 2. Choose File > Import > File.
	 3. �Navigate to the Chapter folder and select the 03_Photomerge folder, then choose the 

file Pano_360.tif.
	 4. Click Open.
	 5. In the Project panel, click the Create a new Folder button.
	 6. �Highlight the folder in the project window and press return to name the folder. Enter 

the name 03_Photomerge and press Return.
	 7. Drag the file 03_Photomerge.tif into the identically named folder.
	 8. Click the disclosure triangle next to the folder 03_Photomerge.
	 9. Choose File > Save the capture your work.

Using the Panorama Script
To create a panorama, we are going to use an After Effects script. The use of scripts allows for 
programmers to customize After Effects and create complex effects. In this lesson, we are going to 
add a third-party script that coverts a panoramic photo into a cylinder and adds a 3D camera to 
the scene. The script called pt_PanoramaMaker.jsx was created by Paul Tuersley at AEnhancers. 
Tip: Get the Latest Script
You can find a detailed discussion at this link – http://aenhancers.com/viewtopic.php?f=9&t=435.
	 1. �In order to install a script, you must quit After Effects. Quit the application and save 

your progress.
	 2. �In the Chapter’s folder, locate the script pt_PanoramaMaker.jsx stored inside the  

folder 03_Photomerge. 
	 3. �Navigate to the After Effects application folder. Open the folder Scripts then open the 

folder ScriptUI Panels.
	 4. Copy the file pt_PanoramaMaker.jsx and copy it to the ScriptsUI Panels folder.
	 5. Re-launch After Effects.
	 6. �In the welcome screen, look in the recent projects list and reopen 9_progress.aep by 

clicking its name.
	 7. Choose Composition > New Composition.
	 8. Name the comp 03_Photomerge and choose the HDV/HDTV 720 29.97 preset.
	 9. Enter duration of 15:00.
	 10. Click OK.
	 11. Drag the new composition into the folder 03_Photomerge.
	 12. Double-click the composition to load it.
	 13. Drag the file Pano_360.tif into the new composition.
	 14. Select the photo layer in the composition.
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	 15. �Choose Window > ptPanorama-
Maker.jsx to open a controller win-
dow for the script.

	 16. �Insect the first field is how much 
of a panoramic photo you have. In 
this care 360 is correct.

	 17. �In the second field, enter the num-
ber of sides of the panorama to be 
broken into to create the cylinder. 
More sides mean a smoother 
curve (but increased render time). 
Enter 24 to match the original 
number of exposures.

	 18. Close the script UI window.
	 19. �Examine the Viewer. You should have to views set from earlier in the chapter. If not, 

click the Select view layout and choose 2 Views – Horizontal.
	 20. Click on the left-hand viewer so it is selected.
	 21. �Double-click the pre-composition called Panorama Precomp to open it. Inside 

you’ll find a Null object to control the panorama and layers to make each face. We’ll 
explore this set more in our next chapter.

	 22. �Close the Panorama Precomp by 
clicking the X in its Timeline tab.

	 23. �In the 03_Photomerge composi-
tion select Layer 1.

	 24. Press R for rotation controls.
	 25. �Drag the Y slider to rotate the 

image on its Y-axis. Experiment 
with different values to explore 
your options.

	 26. Choose File > Save to capture your work. 
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The Next Steps	
I hope you enjoyed this lesson. You can find more by checking out the following resources.
	 • Photoshop for Video Website – www.PhotoshopforVideo.com
	 • RHED Pixel Productions – www.RHEDPixel.tv
	 • Creative COW – www.CreativeCOW.net
	 • Photoshop for Video Podcast – www.CreativeCow.net, iTunes, Adobe TV
	 • Flash for After Effects } After Effects for Flash from Peachpit Press
	 • Photoshop for Video from Focal Press
	 • �Be sure to download the lesson files and get hands-on. Visit the Photoshop World web-

site for downloads.
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